Tóm tắt nhanh
- CVE-2016-10558 là lỗ hổng mức CAO (CVSS 8.1) ảnh hưởng aerospike (aerospike), aerospike.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.7%, cao hơn 77.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.4.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| aerospike | < 2.4.2
| 2.4.2
|
| aerospike npm | < 2.4.2
| 2.4.2
|
Mô tả
Affected versions of aerospike insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running aerospike.
Recommendation
Update to version 2.4.2 or later
Mô tả của NVD
aerospike is an Aerospike add-on module for Node.js. aerospike versions below 2.4.2 download binary resources over HTTP, which leaves the module vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí