Tóm tắt nhanh
- CVE-2016-10571 là lỗ hổng mức CAO (CVSS 8.1) ảnh hưởng bkjs-wand (bkjs-wand project), bkjs-wand.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.7%, cao hơn 76.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.3.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| bkjs-wand | < 0.3.2
| 0.3.2
|
| bkjs-wand npm | < 0.3.2
| 0.3.2
|
Mô tả
Affected versions of bkjs-wand insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running bkjs-wand.
Recommendation
Update to version 0.3.2 or later.
Mô tả của NVD
bkjs-wand is imagemagick wand support for node.js and backendjs bkjs-wand versions lower than 0.3.2 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí