Tóm tắt nhanh
- CVE-2016-10575 là lỗ hổng mức CAO (CVSS 8.1) ảnh hưởng kindlegen (hakatashi), kindlegen.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.7%, cao hơn 77.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.1.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| kindlegen | < 1.1.0
| 1.1.0
|
| kindlegen npm | < 1.1.0
| 1.1.0
|
Mô tả
Affected versions of kindlegen insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running kindlegen.
Recommendation
Update to version 1.1.0 or greater.
Mô tả của NVD
Kindlegen is a simple Node.js wrapper of the official kindlegen program. Kindlegen versions before 1.1.0 download binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí