Tóm tắt nhanh
- CVE-2016-10626 là lỗ hổng mức CAO (CVSS 8.1) ảnh hưởng mystem3 (mystem3 project), mystem3.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.7%, cao hơn 76.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.0.8 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| mystem3 | ≤ 1.0.7
| Chưa có bản vá |
| mystem3 npm | < 1.0.8
| 1.0.8
|
Mô tả
Affected versions of mystem3 insecurely download an executable over an unencrypted HTTP connection.
In scenarios where an attacker has a privileged network position, it is possible to intercept the response and replace the executable with a malicious one, resulting in code execution on the system running mystem3.
Recommendation
Update to version 1.0.8 or later.
Mô tả của NVD
mystem3 is a NodeJS wrapper for the Yandex MyStem 3. mystem3 downloads binary resources over HTTP, which leaves it vulnerable to MITM attacks. It may be possible to cause remote code execution (RCE) by swapping out the requested binary with an attacker controlled binary if the attacker is on the network or positioned in between the user and the remote server.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí