Tóm tắt nhanh
- CVE-2016-2515 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng hawk (hawk project), hawk.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 3.4%, cao hơn 88.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.1.1, 3.1.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| hawk | = 3.1.2= 4.1.0
| Chưa có bản vá |
| hawk npm | ≥ 4.0.0, < 4.1.1< 3.1.3
| 4.1.13.1.3
|
Mô tả
Versions of hawk prior to 3.1.3, or 4.x prior to 4.1.1 are affected by a regular expression denial of service vulnerability related to excessively long headers and URI's.
Recommendation
Update to hawk version 4.1.1 or later.
Mô tả của NVD
Hawk before 3.1.3 and 4.x before 4.1.1 allow remote attackers to cause a denial of service (CPU consumption or partial outage) via a long (1) header or (2) URI that is matched against an improper regular expression.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí