Tóm tắt nhanh
- CVE-2017-0928 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng html-janitor (theguardian), html-janitor.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.0%, cao hơn 63.7% các lỗ hổng khác.
- Chưa có phiên bản vá trong dữ liệu: theo dõi khuyến cáo của nhà cung cấp ở phần Tham khảo.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| html-janitor | = 2.0.2
| Chưa có bản vá |
| html-janitor npm | mọi phiên bản
| Chưa có bản vá |
Mô tả
All versions of html-janitor are vulnerable to cross-site scripting (XSS).
Arbitrary HTML can pass the sanitization process, which can be unexpected and dangerous (XSS) in case user-controlled input is passed to the clean function."
Recommendation
Upgrade to version 2.0.4 or later.
Mô tả của NVD
html-janitor node module suffers from an External Control of Critical State Data vulnerability via user-control of the '_sanitized' variable causing sanitization to be bypassed.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí