| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| mapbox-rails | ≥ 1.0.0, < 1.6.5≥ 2.0.0, < 2.1.7 | 1.6.52.1.7 |
| mapbox | = 1.0.0= 1.0.1= 1.0.2= 1.0.3= 1.0.4= 1.1.0= 1.2.0= 1.3.0= 1.3.1= 1.4.0= 1.4.1= 1.4.2= 1.5.0= 1.5.1= 1.5.2= 1.6.0= 1.6.1= 1.6.2= 1.6.4= 2.0.0= 2.0.1= 2.1.0= 2.1.1= 2.1.2= 2.1.3= 2.1.4= 2.1.5= 2.1.6 | |
| mapbox.js | ≥ 2.0.0, < 2.1.7< 1.6.5 | 2.1.71.6.5 |
Versions 1.x prior to 1.6.5 and 2.x prior to 2.1.7 of mapbox.js are vulnerable to a cross-site-scripting attack in certain uncommon usage scenarios.
If L.mapbox.map or L.mapbox.tileLayer are used to load untrusted TileJSON content from a non-Mapbox URL, it is possible for a malicious user with control over the TileJSON content to inject script content into the "attribution" value of the TileJSON which will be executed in the context of the page using Mapbox.js.
Version 2.x: Update to version 2.1.7 or later. Version 1.x: Update to version 1.6.5 or later.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí