| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| org.apache.spark:spark-core_2.10 | < 2.1.2 | 2.1.2 |
| org.apache.spark:spark-core_2.11 | < 2.1.2 | 2.1.2 |
| pyspark | < 2.1.2 | 2.1.2 |
| spark | = 1.6.0= 1.6.1= 1.6.2= 1.6.3= 2.0.0= 2.0.1= 2.0.2= 2.1.0= 2.1.1 |
In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.1.2, 2.2.0 or later.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí