Tóm tắt nhanh
- CVE-2017-16013 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng hapi (hapijs), hapi.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.6%, cao hơn 75.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 16.1.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| hapi | ≥ 15.0.0, ≤ 16.1.0
| Chưa có bản vá |
| hapi npm | ≥ 15.0.0, < 16.1.1
| 16.1.1
|
Mô tả
Affected versions of hapi will crash or lock the event loop when a malformed accept-encoding header is recieved.
Recommendation
Update to version 16.1.1 or later.
Mô tả của NVD
hapi is a web and services application framework. When hapi >= 15.0.0 <= 16.1.0 encounters a malformed `accept-encoding` header an uncaught exception is thrown. This may cause hapi to crash or to hang the client connection until the timeout period is reached.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí