Tóm tắt nhanh
- CVE-2017-16019 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng gitbook (gitbook), gitbook.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.92%, cao hơn 60.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.2.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| gitbook | < 3.2.2
| 3.2.2
|
| gitbook npm | < 3.2.2
| 3.2.2
|
Mô tả
Affected versions of gitbook do not properly sanitize user input outside of backticks, which may result in cross-site scripting in the online reader.
Recommendation
Update to version 3.2.2 or later.
Mô tả của NVD
GitBook is a command line tool (and Node.js library) for building beautiful books using GitHub/Git and Markdown (or AsciiDoc). Stored Cross-Site-Scripting (XSS) is possible in GitBook before 3.2.2 by including code outside of backticks in any ebook. This code will be executed on the online reader.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí