Tóm tắt nhanh
- CVE-2017-16021 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng uri-js (garycourt), uri-js.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.3%, cao hơn 71.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.0.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| uri-js | ≤ 2.1.1
| Chưa có bản vá |
| uri-js npm | < 3.0.0
| 3.0.0
|
Mô tả
Affected versions of uri-js is susceptible to a regular expression denial of service vulnerability when user input is sent to the .parse() method.
Recommendation
Update to v3.0.0 or later.
Mô tả của NVD
uri-js is a module that tries to fully implement RFC 3986. One of these features is validating whether or not a supplied URL is valid or not. To do this, uri-js uses a regular expression, This regular expression is vulnerable to redos. This causes the program to hang and the CPU to idle at 100% usage while uri-js is trying to validate if the supplied URL is valid or not. To check if you're vulnerable, look for a call to `require("uri-js").parse()` where a user is able to send their own input. This affects uri-js 2.1.1 and earlier.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí