Tóm tắt nhanh
- CVE-2017-16025 là lỗ hổng mức TRUNG BÌNH (CVSS 5.9) ảnh hưởng nes (hapijs), nes.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.9%, cao hơn 79.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.4.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| nes | ≤ 6.4.0
| Chưa có bản vá |
| nes npm | < 6.4.1
| 6.4.1
|
Mô tả
Affected versions of nes are vulnerable to denial of service when given an invalid cookie header, and websocket authentication is set to cookie. Submitting an invalid cookie on the websocket upgrade request will cause the node process to throw and exit.
Recommendation
Update to version 6.4.1 or later.
Mô tả của NVD
Nes is a websocket extension library for hapi. Hapi is a webserver framework. Versions below and including 6.4.0 have a denial of service vulnerability via an invalid Cookie header. This is only present when websocket authentication is set to `cookie`. Submitting an invalid cookie on the websocket upgrade request will cause the node process to error out.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí