Tóm tắt nhanh
- CVE-2017-16042 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng growl (growl project), growl.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 4.6%, cao hơn 91.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.10.2, 1.10.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| growl | < 1.10.2
| 1.10.2
|
| growl npm | < 1.10.0
| 1.10.0
|
Mô tả
Affected versions of growl do not properly sanitize input prior to passing it into a shell command, allowing for arbitrary command execution.
Recommendation
Update to version 1.10.0 or later.
Mô tả của NVD
Growl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí