Tóm tắt nhanh
- CVE-2017-16111 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng content (content project), content.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.1%, cao hơn 65.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.0.7 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| content | ≤ 3.0.5
| Chưa có bản vá |
| content npm | < 3.0.7
| 3.0.7
|
Mô tả
Affected versions of content are vulnerable to a regular expression denial of service when parsing malicious Content-Type and Content-Disposition headers.
Recommendation
Update to version 3.0.6 or later.
Mô tả của NVD
The content module is a module to parse HTTP Content-* headers. It is used by the hapijs framework to provide this functionality. The module is vulnerable to regular expression denial of service when passed a specifically crafted Content-Type or Content-Disposition header.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí