Tóm tắt nhanh
- CVE-2017-16118 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng forwarded (forwarded project), forwarded.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.9%, cao hơn 79.3% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.1.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| forwarded | < 0.1.2
| 0.1.2
|
| forwarded npm | < 0.1.2
| 0.1.2
|
Mô tả
Affected versions of forwarded are vulnerable to regular expression denial of service when parsing specially crafted user input.
Recommendation
Update to version 0.1.2 or later
Mô tả của NVD
The forwarded module is used by the Express.js framework to handle the X-Forwarded-For header. It is vulnerable to a regular expression denial of service when it's passed specially crafted input to parse. This causes the event loop to be blocked causing a denial of service condition.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí