Tóm tắt nhanh
- CVE-2017-18214 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng moment (momentjs), nessus (tenable), moment.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 3.6%, cao hơn 89.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.19.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| moment | ≤ 2.19.2
| Chưa có bản vá |
| nessus | ≤ 8.2.3
| Chưa có bản vá |
| moment npm | < 2.19.3
| 2.19.3
|
Mô tả
Affected versions of moment are vulnerable to a low severity regular expression denial of service when parsing dates as strings.
Recommendation
Update to version 2.19.3 or later.
Mô tả của NVD
The moment module before 2.19.3 for Node.js is prone to a regular expression denial of service via a crafted date string, a different vulnerability than CVE-2016-4055.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí