Tóm tắt nhanh
- CVE-2017-18342 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng pyyaml, pyyaml (pyyaml).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 5.7%, cao hơn 93.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 5.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| pyyaml PyPI | < 5.1
| 5.1
|
| pyyaml | < 5.1
| 5.1
|
Mô tả
In PyYAML before 5.1, the yaml.load() API could execute arbitrary code. In other words, yaml.safe_load is not used.
This was intended to be fixed in 4.1, but due to breaking changes, 4.1 was yanked and 5.1 contains the patch for CVE-2017-18342.
Mô tả của NVD
In PyYAML before 5.1, the yaml.load() API could execute arbitrary code if used with untrusted data. The load() function has been deprecated in version 5.1 and the 'UnsafeLoader' has been introduced for backward compatibility with the function.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí