Tóm tắt nhanh
- CVE-2018-1000086 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng pym.js (npr), pym.js.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.0%, cao hơn 63.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.3.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| pym.js | ≥ 0.4.2, ≤ 1.3.1
| Chưa có bản vá |
| pym.js npm | ≥ 0.4.2, < 1.3.2
| 1.3.2
|
Mô tả
NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross Site Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function.
https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 can result in Arbitrary javascript code execution. This attack appears to be exploitable if the Attacker gains full javascript access to pages with Pym.js embeds, or when user visits an attacker-crafted page. This vulnerability appears to have been fixed in versions 1.3.2 and later.
Mô tả của NVD
NPR Visuals Team Pym.js version versions 0.4.2 up to 1.3.1 contains a Cross ite Request Forgery (CSRF) vulnerability in Pym.js _onNavigateToMessage function. https://github.com/nprapps/pym.js/blob/master/src/pym.js#L573 that can result in Arbitrary javascript code execution. This attack appear to be exploitable via Attacker gains full javascript access to pages with Pym.js embeds when user visits an attacker crafted page.. This vulnerability appears to have been fixed in versions 1.3.2 and later.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí