Tóm tắt nhanh
- CVE-2018-1000088 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng doorkeeper, doorkeeper (doorkeeper project).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.4%, cao hơn 73.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.2.6 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| doorkeeper RubyGems | ≥ 2.1.0, < 4.2.6
| 4.2.6
|
| doorkeeper | ≥ 2.1.0, ≤ 4.2.5
| Chưa có bản vá |
Mô tả
Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.
Mô tả của NVD
Doorkeeper version 2.1.0 through 4.2.5 contains a Cross Site Scripting (XSS) vulnerability in web view's OAuth app form, user authorization prompt web view that can result in Stored XSS on the OAuth Client's name will cause users interacting with it will execute payload. This attack appear to be exploitable via The victim must be tricked to click an opaque link to the web view that runs the XSS payload. A malicious version virtually indistinguishable from a normal link.. This vulnerability appears to have been fixed in 4.2.6, 4.3.0.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí