Tóm tắt nhanh
- CVE-2018-1000620 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng cryptiles (cryptiles project), cryptiles.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.7%, cao hơn 77.1% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.1.2, 3.1.3 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| cryptiles | ≥ 4.1.0, < 4.1.2< 3.1.3
| 4.1.23.1.3
|
| cryptiles npm | ≥ 3.1.0, < 3.1.3≥ 4.0.0, < 4.1.2
| 3.1.34.1.2
|
Mô tả
Versions of cryptiles prior to 4.1.2 are vulnerable to Insufficient Entropy. The randomDigits() method does not provide sufficient entropy and its generates digits that are not evenly distributed.
Recommendation
Upgrade to version 4.1.2. The package is deprecated and has been moved to @hapi/cryptiles and it is strongly recommended to use the maintained package.
Mô tả của NVD
Eran Hammer cryptiles version 4.1.1 earlier contains a CWE-331: Insufficient Entropy vulnerability in randomDigits() method that can result in An attacker is more likely to be able to brute force something that was supposed to be random.. This attack appear to be exploitable via Depends upon the calling application.. This vulnerability appears to have been fixed in 4.1.2.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí