Tóm tắt nhanh
- CVE-2018-1002203 là lỗ hổng mức TRUNG BÌNH (CVSS 5.5) ảnh hưởng unzipper (unzipper project), unzipper.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 10.6%, cao hơn 95.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.8.13 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| unzipper | < 0.8.13
| 0.8.13
|
| unzipper npm | < 0.8.13
| 0.8.13
|
Mô tả
Versions of unzipper before 0.8.13 are vulnerable to arbitrary file write when used to extract a specifically crafted archive that contains path traversal filenames (../../file.txt for example).
Recommendation
Update to version 0.3.18 or later.
Mô tả của NVD
unzipper npm library before 0.8.13 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí