Tóm tắt nhanh
- CVE-2018-16491 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng node.extend (dreamerslab), node.extend.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.7%, cao hơn 77.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.0.1, 1.1.7 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| node.extend | ≥ 2.0.0, < 2.0.1< 1.1.7
| 2.0.11.1.7
|
| node.extend npm | ≥ 2.0.0, < 2.0.1< 1.1.7
| 2.0.11.1.7
|
Mô tả
Versions of node.extend before 1.1.7 or 2.0.1 are vulnerable to prototype pollution.
Recommendation
Update to version 1.1.7, 2.0.1 or later.
Mô tả của NVD
A prototype pollution vulnerability was found in node.extend <1.1.7, ~<2.0.1 that allows an attacker to inject arbitrary properties onto Object.prototype.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí