Tóm tắt nhanh
- CVE-2018-3750 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng deep extend (deep extend project), deep-extend.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.1%, cao hơn 82.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.5.1 hoặc mới hơn.
Mô tả
Versions of deep-extend before 0.5.1 are vulnerable to prototype pollution.
Recommendation
Update to version 0.5.1 or later.
Mô tả của NVD
The utilities function in all versions <= 0.5.0 of the deep-extend node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí