Tóm tắt nhanh
- CVE-2018-3772 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng whereis (whereis project), whereis.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.8%, cao hơn 86.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.4.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| whereis | < 0.4.1
| 0.4.1
|
| whereis npm | < 0.4.1
| 0.4.1
|
Mô tả
Versions of whereis before 0.4.1 are vulnerable to command injection if untrusted user input is passed into whereis.
Recommendation
Update to version 0.4.1 or later.
Mô tả của NVD
Concatenating unsanitized user input in the `whereis` npm module < 0.4.1 allowed an attacker to execute arbitrary commands. The `whereis` module is deprecated and it is recommended to use the `which` npm module instead.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí