Tóm tắt nhanh
- CVE-2018-7651 là lỗ hổng mức TRUNG BÌNH (CVSS 5.9) ảnh hưởng ssri (ssri project), ssri.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.7%, cao hơn 77.4% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 5.2.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| ssri | < 5.2.2
| 5.2.2
|
| ssri npm | < 5.2.2
| 5.2.2
|
Mô tả
Version of ssri prior to 5.2.2 are vulnerable to regular expression denial of service (ReDoS) when using strict mode.
Recommendation
Update to version 5.2.2 or later.
Mô tả của NVD
index.js in the ssri module before 5.2.2 for Node.js is prone to a regular expression denial of service vulnerability in strict mode functionality via a long base64 hash string.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí