| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| k8s.io/kubernetes | ≥ 1.0.0, < 1.13.12≥ 1.14.0, < 1.14.8≥ 1.15.0, < 1.15.5≥ 1.16.0, < 1.16.2 | 1.13.121.14.81.15.51.16.2 |
| kubernetes | ≥ 1.1.0, ≤ 1.12.10≥ 1.13.0, < 1.13.12≥ 1.14.0, < 1.14.8≥ 1.15.0, < 1.15.5≥ 1.16.0, < 1.16.2 | 1.13.121.14.81.15.51.16.2 |
| openshift container platform | = 3.10= 3.11= 3.9 |
Improper input validation in the Kubernetes API server in versions v1.0-1.12 and versions prior to v1.13.12, v1.14.8, v1.15.5, and v1.16.2 allows authorized users to send malicious YAML or JSON payloads, causing the API server to consume excessive CPU or memory, potentially crashing and becoming unavailable. Prior to v1.14.0, default RBAC policy authorized anonymous users to submit requests that could trigger this vulnerability. Clusters upgraded from a version prior to v1.14.0 keep the more permissive policy by default for backwards compatibility.
k8s.io/kubernetes/pkg/apiserver
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí