Tóm tắt nhanh
- CVE-2019-15607 là lỗ hổng mức TRUNG BÌNH (CVSS 5.4) ảnh hưởng node-red (nodered), node-red.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.64%, cao hơn 50.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.20.8 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| node-red | ≤ 0.20.7
| Chưa có bản vá |
| node-red npm | < 0.20.8
| 0.20.8
|
Mô tả
Versions of node-red prior to 0.20.8are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize the name field in new Flows, allowing attackers to execute arbitrary JavaScript in the victim's browser.
Recommendation
Upgrade to version 0.18.6 or later.
Mô tả của NVD
A stored XSS vulnerability is present within node-red (version: <= 0.20.7) npm package, which is a visual tool for wiring the Internet of Things. This issue will allow the attacker to steal session cookies, deface web applications, etc.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí