Tóm tắt nhanh
- CVE-2019-16761 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng slp-validate (simpleledger), slp-validate.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.99%, cao hơn 62.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.0.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| slp-validate | = 1.0.0
| Chưa có bản vá |
| slp-validate npm | ≥ 1.0.0, < 1.0.1
| 1.0.1
|
Mô tả
Versions of slp-validate prior to 1.0.1 are vulnerable to a validation bypass. Bitcoin scripts may cause the validation result from slp-validate to differ from the specified SLP consensus. This allows an attacker to create a Bitcoin script that causes a hard-fork from the SLP consensus.
Recommendation
Upgrade to version 1.0.1 or later.
Mô tả của NVD
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the [email protected] npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. All versions >1.0.0 have been patched.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí