Tóm tắt nhanh
- CVE-2019-16762 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng slpjs (simpleledger), slpjs.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.1%, cao hơn 65.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.21.4 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| slpjs | < 0.21.4
| 0.21.4
|
| slpjs npm | < 0.21.4
| 0.21.4
|
Mô tả
Validator parsing discrepancy due to string encoding
Impact
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus.
Patches
All versions > 0.21.3 are patched.
Workarounds
Upgrade to any version >= 0.21.4.
References
The bug was located and fixed here.
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
A specially crafted Bitcoin script can cause a discrepancy between the specified SLP consensus rules and the validation result of the slpjs npm package. An attacker could create a specially crafted Bitcoin script in order to cause a hard-fork from the SLP consensus. Affected users can upgrade to any version >= 0.21.4.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí