Tóm tắt nhanh
- CVE-2019-16763 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng pannellum (pannellum), pannellum.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.70%, cao hơn 53.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.5.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| pannellum | ≥ 2.5.0, ≤ 2.5.4
| Chưa có bản vá |
| pannellum npm | ≥ 2.5.0, < 2.5.5
| 2.5.5
|
Mô tả
Versions of pannellum prior to 2.5.6 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize URLs for data URIs, which may allow attackers to execute arbitrary code in a victim's browser.
Recommendation
Upgrade to version 2.5.6 or later.
Mô tả của NVD
In Pannellum from 2.5.0 through 2.5.4 URLs were not sanitized for data URIs (or vbscript:), allowing for potential XSS attacks. Such an attack would require a user to click on a hot spot to execute and would require an attacker-provided configuration. The most plausible potential attack would be if pannellum.htm was hosted on a domain that shared cookies with the targeted site's user authentication; an <iframe> could then be embedded on the attacker's site using pannellum.htm from the targeted site, which would allow the attacker to potentially access information from the targeted site as the authenticated user (or worse if the targeted site did not have adequate CSRF protections) if the user clicked on a hot spot in the attacker's embedded panorama viewer. This was patched in version 2.5.5.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí