Tóm tắt nhanh
- CVE-2019-16769 là lỗ hổng mức TRUNG BÌNH (CVSS 5.4) ảnh hưởng serialize-javascript (verizon), serialize-javascript.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 0.80%, cao hơn 56.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.1.1 hoặc mới hơn.
Mô tả
Versions of serialize-javascript prior to 2.1.1 are vulnerable to Cross-Site Scripting (XSS). The package fails to sanitize serialized regular expressions. This vulnerability does not affect Node.js applications.
Recommendation
Upgrade to version 2.1.1 or later.
Mô tả của NVD
The serialize-javascript npm package before version 2.1.1 is vulnerable to Cross-site Scripting (XSS). It does not properly mitigate against unsafe characters in serialized regular expressions. This vulnerability is not affected on Node.js environment since Node.js's implementation of RegExp.prototype.toString() backslash-escapes all forward slashes in regular expressions. If serialized data of regular expression objects are used in an environment other than Node.js, it is affected by this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí