Tóm tắt nhanh
- CVE-2019-19588 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng validators, validators (validators project).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.5%, cao hơn 73.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.12.6 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| validators PyPI | ≥ 0.12.2, < 0.12.6
| 0.12.6
|
| validators | ≥ 0.12.2, ≤ 0.12.5
| Chưa có bản vá |
Mô tả
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
Mô tả của NVD
The validators package 0.12.2 through 0.12.5 for Python enters an infinite loop when validators.domain is called with a crafted domain string. This is fixed in 0.12.6.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí