Tóm tắt nhanh
- CVE-2019-19609 là lỗ hổng mức CAO (CVSS 7.2) ảnh hưởng strapi (strapi), strapi.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 54.1%, cao hơn 99.0% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.0.0-beta.17.8 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| strapi | = 3.0.0≤ 1.6.4
| Chưa có bản vá |
| strapi npm | < 3.0.0-beta.17.8
| 3.0.0-beta.17.8
|
Mô tả
Versions of strapi before 3.0.0-beta.17.8 are vulnerable to Command Injection. The package fails to sanitize plugin names in the /admin/plugins/install/ route. This may allow an authenticated attacker with admin privileges to run arbitrary commands in the server.
Recommendation
Upgrade to version 3.0.0-beta.17.8 or later
Mô tả của NVD
The Strapi framework before 3.0.0-beta.17.8 is vulnerable to Remote Code Execution in the Install and Uninstall Plugin components of the Admin panel, because it does not sanitize the plugin name, and attackers can inject arbitrary shell commands to be executed by the execa function.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí