Tóm tắt nhanh
- CVE-2019-5421 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng devise, devise (plataformatec).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.6%, cao hơn 75.2% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.6.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| devise RubyGems | < 4.6.0
| 4.6.0
|
| devise | ≤ 4.5.0
| Chưa có bản vá |
Mô tả
Devise ruby gem before 4.6.0 when the lockable module is used is vulnerable to a time-of-check time-of-use (TOCTOU) race condition due to increment_failed_attempts within the Devise::Models::Lockable class not being concurrency safe.
Mô tả của NVD
Plataformatec Devise version 4.5.0 and earlier, using the lockable module contains a CWE-367 vulnerability in The `Devise::Models::Lockable` class, more specifically at the `#increment_failed_attempts` method. File location: lib/devise/models/lockable.rb that can result in Multiple concurrent requests can prevent an attacker from being blocked on brute force attacks. This attack appear to be exploitable via Network connectivity - brute force attacks. This vulnerability appears to have been fixed in 4.6.0 and later.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí