Tóm tắt nhanh
- CVE-2020-15125 là lỗ hổng mức CAO (CVSS 7.7) ảnh hưởng auth0.js (auth0), auth0.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.5%, cao hơn 74.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.27.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| auth0.js | < 2.27.1
| 2.27.1
|
| auth0 npm | < 2.27.1
| 2.27.1
|
Mô tả
Overview
Versions before and including 2.27.0 use a block list of specific keys that should be sanitized from the request object contained in the error object. When a request to Auth0 management API fails, the key for Authorization header is not sanitized and the Authorization header value can be logged exposing a bearer token.
Am I affected?
You are affected by this vulnerability if all of the following conditions apply:
How to fix that?
Upgrade to version 2.27.1
Will this update impact my users?
The fix provided in patch will not affect your users.
Credit
http://github.com/osdiab
Mô tả của NVD
In auth0 (npm package) versions before 2.27.1, a DenyList of specific keys that should be sanitized from the request object contained in the error object is used. The key for Authorization header is not sanitized and in certain cases the Authorization header value can be logged exposing a bearer token. You are affected by this vulnerability if you are using the auth0 npm package, and you are using a Machine to Machine application authorized to use Auth0's management API
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí