Tóm tắt nhanh
- CVE-2020-4051 là lỗ hổng mức TRUNG BÌNH (CVSS 5.4) ảnh hưởng dijit (openjsf), dijit.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.2%, cao hơn 67.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.12.9, 1.13.8, 1.14.7, 1.15.4 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| dijit | ≥ 1.12.0, < 1.12.9≥ 1.13.0, < 1.13.8≥ 1.14.0, < 1.14.7≥ 1.15.0, < 1.15.4≥ 1.16.0, < 1.16.3< 1.11.11
| 1.12.91.13.81.14.71.15.41.16.31.11.11
|
| dijit npm | ≥ 1.12.0, < 1.12.9≥ 1.13.0, < 1.13.8≥ 1.14.0, < 1.14.7≥ 1.15.0, < 1.15.4≥ 1.16.0, < 1.16.3< 1.11.11
| 1.12.91.13.81.14.71.15.41.16.31.11.11
|
Mô tả
Impact
XSS possible for users of the Dijit Editor's LinkDialog plugin
Patches
Yes, 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3
Workarounds
Users may apply the patch made in these releases.
For more information
If you have any questions or comments about this advisory, open an issue in dojo/dijit
Mô tả của NVD
In Dijit before versions 1.11.11, and greater than or equal to 1.12.0 and less than 1.12.9, and greater than or equal to 1.13.0 and less than 1.13.8, and greater than or equal to 1.14.0 and less than 1.14.7, and greater than or equal to 1.15.0 and less than 1.15.4, and greater than or equal to 1.16.0 and less than 1.16.3, there is a cross-site scripting vulnerability in the Editor's LinkDialog plugin. This has been fixed in 1.11.11, 1.12.9, 1.13.8, 1.14.7, 1.15.4, 1.16.3.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí