Tóm tắt nhanh
- CVE-2021-21238 là lỗ hổng mức TRUNG BÌNH (CVSS 6.5) ảnh hưởng pysaml2, pysaml2 (pysaml2 project).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.1%, cao hơn 65.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 6.5.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| pysaml2 PyPI | < 6.5.0
| 6.5.0
|
| pysaml2 | < 6.5.0
| 6.5.0
|
Mô tả
Impact
All users of pysaml2 that use the default CryptoBackendXmlSec1 backend and need to verify signed SAML documents are impacted. pysaml2 <= 6.4.1 does not validate the SAML document against an XML schema. This allows invalid XML documents to trick the verification process, by presenting elements with a valid signature inside elements whose content has been malformed. The verification is offloaded to xmlsec1 and xmlsec1 will not validate every signature in the given document, but only the first it finds in the given scope.
Patches
Users should upgrade to pysaml2 v6.5.0.
Workarounds
No workaround provided at this point.
References
No references provided at this point.
Credits
- Victor Schönfelder Garcia (isits AG International School of IT Security)
- Juraj Somorovsky (Paderborn University)
- Vladislav Mladenov (Ruhr University Bochum)
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
PySAML2 is a pure python implementation of SAML Version 2 Standard. PySAML2 before 6.5.0 has an improper verification of cryptographic signature vulnerability. All users of pysaml2 that need to validate signed SAML documents are impacted. The vulnerability is a variant of XML Signature wrapping because it did not validate the SAML document against an XML schema. This allowed invalid XML documents to be processed and such a document can trick pysaml2 with a wrapped signature. This is fixed in PySAML2 6.5.0.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí