Tóm tắt nhanh
- CVE-2021-21317 là lỗ hổng mức TRUNG BÌNH (CVSS 5.3) ảnh hưởng uap-core (uap-core project), uap-core.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.5%, cao hơn 84.9% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.11.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| uap-core | < 0.11.0
| 0.11.0
|
| uap-core npm | < 0.11.0
| 0.11.0
|
Mô tả
Impact
Some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings.
Patches
Please update uap-core to >= v0.11.0
Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
Mô tả của NVD
uap-core in an open-source npm package which contains the core of BrowserScope's original user agent string parser. In uap-core before version 0.11.0, some regexes are vulnerable to regular expression denial of service (REDoS) due to overlapping capture groups. This allows remote attackers to overload a server by setting the User-Agent header in an HTTP(S) request to maliciously crafted long strings. This is fixed in version 0.11.0. Downstream packages such as uap-python, uap-ruby etc which depend upon uap-core follow different version schemes.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí