Tóm tắt nhanh
- CVE-2021-27292 là lỗ hổng mức CAO (CVSS 7.5) ảnh hưởng ua-parser-js (ua-parser-js project), ua-parser-js.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 3.4%, cao hơn 88.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.7.24 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| ua-parser-js | ≥ 0.7.14, < 0.7.24
| 0.7.24
|
| ua-parser-js npm | ≥ 0.7.14, < 0.7.24
| 0.7.24
|
Mô tả
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
Mô tả của NVD
ua-parser-js >= 0.7.14, fixed in 0.7.24, uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí