Tóm tắt nhanh
- CVE-2021-29625 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng vrana/adminer, adminer (adminer).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 9.6%, cao hơn 95.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 4.8.1 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| vrana/adminer Packagist | ≥ 4.7.8, < 4.8.1
| 4.8.1
|
| adminer | ≥ 4.6.1, < 4.8.1
| 4.8.1
|
Mô tả
Impact
Users of MySQL, MariaDB, PgSQL and SQLite are affected. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a pdo_ extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected.
Patches
Patched by 4043092, included in version 4.8.1.
Workarounds
Do both:
- Use browser supporting strict CSP.
- Enable the native PHP extensions (e.g.
mysqli) or disable displaying PHP errors (display_errors).
References
https://sourceforge.net/p/adminer/bugs-and-features/797/
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí