| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| jsrsasign | ≤ 10.1.13 | |
| jsrsasign | < 10.2.0 | 10.2.0 |
Vulnerable jsrsasign will accept RSA signature with improper PKCS#1.5 padding.
Decoded RSA signature value consists following form:
01(ff...(8 or more ffs)...ff)00[ASN.1 OF DigestInfo]
Its byte length must be the same as RSA key length, however such checking was not sufficient.
To make crafted message for practical attack is very hard.
Users validating RSA signature should upgrade to 10.2.0 or later.
There is no workaround. Not to use RSA signature validation in jsrsasign.
Thanks to Daniel Yahyazadeh @yahyazadeh for reporting and analyzing this vulnerability.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí