Tóm tắt nhanh
- CVE-2021-32702 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng nextjs-auth0 (auth0), @auth0/nextjs-auth0.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.4%, cao hơn 72.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 1.4.2 hoặc mới hơn.
Mô tả
Overview
Versions before and including 1.4.1 are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the error query parameter which is then processed by the callback handler as an error message.
Am I affected?
You are affected by this vulnerability if you are using @auth0/nextjs-auth0 version 1.4.1 or lower unless you are using custom error handling that does not return the error message in an HTML response.
How to fix that?
Upgrade to version 1.4.2.
Will this update impact my users?
The fix adds basic HTML escaping to the error message and it should not impact your users.
Credit
https://github.com/inian
https://github.com/git-ishanpatel
Mô tả của NVD
The Auth0 Next.js SDK is a library for implementing user authentication in Next.js applications. Versions before and including `1.4.1` are vulnerable to reflected XSS. An attacker can execute arbitrary code by providing an XSS payload in the `error` query parameter which is then processed by the callback handler as an error message. You are affected by this vulnerability if you are using `@auth0/nextjs-auth0` version `1.4.1` or lower **unless** you are using custom error handling that does not return the error message in an HTML response. Upgrade to version `1.4.1` to resolve. The fix adds basic HTML escaping to the error message and it should not impact your users.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí