Tóm tắt nhanh
- CVE-2021-3377 là lỗ hổng mức TRUNG BÌNH (CVSS 6.1) ảnh hưởng ansi up (ansi up project), ansi_up.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 8.0%, cao hơn 94.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 5.0.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| ansi up | < 5.0.0
| 5.0.0
|
| ansi_up npm | < 5.0.0
| 5.0.0
|
Mô tả
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Mô tả của NVD
The npm package ansi_up converts ANSI escape codes into HTML. In ansi_up v4, ANSI escape codes can be used to create HTML hyperlinks. Due to insufficient URL sanitization, this feature is affected by a cross-site scripting (XSS) vulnerability. This issue is fixed in v5.0.0.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí