Tóm tắt nhanh
- CVE-2021-39160 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng nbgitpuller, nbgitpuller (jupyterhub).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.7%, cao hơn 77.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 0.10.2 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| nbgitpuller PyPI | ≥ 0.9.0, < 0.10.2
| 0.10.2
|
| nbgitpuller | ≥ 0.9.0, < 0.10.2
| 0.10.2
|
Mô tả
Impact
Due to an unsanitized input, visiting maliciously crafted links could result in arbitrary code execution in the user environment.
Patches
0.10.2
Workarounds
None, other than upgrade to 0.10.2 or downgrade to 0.8.x.
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
nbgitpuller is a Jupyter server extension to sync a git repository one-way to a local path. Due to unsanitized input, visiting maliciously crafted links could result in arbitrary code execution in the user environment. This has been resolved in version 0.10.2 and all users are advised to upgrade. No work around exist for users who can not upgrade.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí