Tóm tắt nhanh
- CVE-2021-41116 là lỗ hổng mức NGHIÊM TRỌNG (CVSS 9.8) ảnh hưởng composer/composer, composer (getcomposer), tenable.sc (tenable).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.8%, cao hơn 86.6% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.1.9, 1.10.23, 5.21.0 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| composer/composer Packagist | ≥ 2.0.0-alpha1, < 2.1.9< 1.10.23
| 2.1.91.10.23
|
| composer | ≥ 2.0.0, < 2.1.9< 1.10.23
| 2.1.91.10.23
|
| tenable.sc | < 5.21.0
| 5.21.0
|
Mô tả
Impact
Windows users running Composer to install untrusted dependencies are affected and should definitely upgrade for safety. Other OSs and WSL are not affected.
Patches
1.10.23 and 2.1.9 fix the issue
Workarounds
None
Mô tả của NVD
Composer is an open source dependency manager for the PHP language. In affected versions windows users running Composer to install untrusted dependencies are subject to command injection and should upgrade their composer version. Other OSs and WSL are not affected. The issue has been resolved in composer versions 1.10.23 and 2.1.9. There are no workarounds for this issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí