Tóm tắt nhanh
- CVE-2021-41265 là lỗ hổng mức CAO (CVSS 8.8) ảnh hưởng flask-appbuilder, flask-appbuilder (dpgaspar).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.3%, cao hơn 70.8% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 3.3.4 hoặc mới hơn.
Mô tả
Impact
Improper authentication on the REST API. Allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. Only affects non database authentication types, and new REST API endpoints.
Patches
Upgrade to Flask-AppBuilder 3.3.4
For more information
If you have any questions or comments about this advisory:
Mô tả của NVD
Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí