Tóm tắt nhanh
- CVE-2021-4231 là lỗ hổng mức TRUNG BÌNH (CVSS 5.4) ảnh hưởng angular (angular), angularjs (angularjs), @angular/core.
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 1.2%, cao hơn 67.7% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 11.0.5, 11.1.0-next.3, 10.2.5 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| angular | = 11.1.0
| Chưa có bản vá |
| angularjs | < 11.0.5
| 11.0.5
|
| @angular/core npm | ≥ 11.0.0, < 11.0.5≥ 11.1.0-next.0, < 11.1.0-next.3< 10.2.5
| 11.0.511.1.0-next.310.2.5
|
Mô tả
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 10.2.5, 11.0.5 or 11.1.0-next.3 is advised to to address this issue.
Mô tả của NVD
A vulnerability was found in Angular up to 11.0.4/11.1.0-next.2. It has been classified as problematic. Affected is the handling of comments. The manipulation leads to cross site scripting. It is possible to launch the attack remotely but it might require an authentication first. Upgrading to version 11.0.5 and 11.1.0-next.3 is able to address this issue. The name of the patch is ba8da742e3b243e8f43d4c63aa842b44e14f2b09. It is recommended to upgrade the affected component.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí