Tóm tắt nhanh
- CVE-2021-43811 là lỗ hổng mức CAO (CVSS 7.8) ảnh hưởng sockeye, sockeye (amazon).
- Xác suất bị khai thác trong 30 ngày tới (EPSS): 2.5%, cao hơn 84.5% các lỗ hổng khác.
- Cách xử lý: cập nhật lên 2.3.24 hoặc mới hơn.
| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|
| sockeye PyPI | < 2.3.24
| 2.3.24
|
| sockeye | < 2.3.24
| 2.3.24
|
Mô tả
Impact
Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files.
An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally.
Patches
The issue is fixed in version 2.3.24 and above by #964.
For more information
If you have any questions or comments about this advisory:
Attribution
This vulnerability was reported by Masatoshi Yoshizawa of yamory Security Team.
Mô tả của NVD
Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí