| Gói / sản phẩm | Phiên bản bị ảnh hưởng | Phiên bản đã vá |
|---|---|---|
| activestorage | ≥ 5.2.0, < 5.2.6.3≥ 6.0.0, < 6.0.4.7≥ 6.1.0, < 6.1.4.7≥ 7.0.0, < 7.0.2.3 | 5.2.6.36.0.4.76.1.4.77.0.2.3 |
| active storage | ≥ 5.2.0, < 5.2.6.3≥ 6.0.0, < 6.0.4.7≥ 6.1.0, < 6.1.4.7≥ 7.0.0, < 7.0.2.3 | 5.2.6.36.0.4.76.1.4.77.0.2.3 |
The Active Storage module of Rails starting with version 5.2.0 is possibly vulnerable to code injection. This issue was patched in versions 5.2.6.3, 6.0.4.7, 6.1.4.7, and 7.0.2.3. To work around this issue, applications should implement a strict allow-list on accepted transformation methods or arguments. Additionally, a strict ImageMagick security policy will help mitigate this issue.
Bạn đang dùng một trong các sản phẩm này? Quét site để biết có đang lộ phiên bản có lỗ hổng không.
Quét site miễn phí